PROGRAMABILNI LOGICKI

KONTROLERI (PLC)
| LADDER DIJAGRAMI




* PLC kontrolisu veCinu mehanicCkih procesa u mnogim oblastima
proizvodnje.



" JEEETSTO JE PLC?

PLC predstavlja industrijski racunar koji, u cilju
automatizacije procesa i/ili masina, nadzire ulaze,
donosi odluke na osnovu programa i kontrolise izlaze.
Obezbjeduje interfejs sa senzorima i aktuatorima.

Radi u industrijskom okruzenju.



" AEENNNKONVPONENTE PLC-a?

PLC se sastoji iz:

- Ulaznih modula
- Prihvatanje i konvertovanje signal sa senzora u logicCki signal

- CPU (Centralna procesorska jedinica)
- lzvrSavanje kontrolnih instrukcija

- lzlazni moduli
- Konvertovanje kontrolnih instrukciju u signal pogodan za upravljanje

aktuatorima

Dodatne PLC komponente:
- Uredaj za programiranje
- Interfejs prema operatoru
- Prikaz informacija o procesu
- Omogucavanje unosa novih vrijednosti parametara



" --EEEENEUNKCIONISANJE PLC-a?

m Kontinualno skeniranje

ladder diagrama.
m Sastoji se od 3 vazna 1
koraka.
CHECK INPUT STATUS
EXECUTE PROGRAM
I
UPDATE OUTPUT STATUS

l




" EEENRENKCIONISANJE PLC-a?

m Dodatne funkcije

Input
Madule

CPU

—> | Central Processing

Linit

F'mgmmmrng

Quiput
Module

Oporator
Interface




" JAEENNNNREL EJNI SISTEMI

OLD CONTROL SYSTEMS

Relejni sistemi — puno zica za povezivanje
TesSkoce prilikom popravki ili zamjena
TeSkocCe u pronalazenju greSaka; zahtijeva
iIskusnu radnu snagul.

Kada se pojavi problem, ne moze se predvidjeti
trajanje zastoja. Obi¢no traje dugo.

PreviSe pokretnih djelova.




" JAEENNNPREDNOSI PLC-a

Broj zica redukovan oko 80%.

Brza i jednostavna detekcija reske.

Promjena programa ne podrzumijeva promjenu ozicenja.
Potrebno manje rezervnih djelova.

Niza cijena za vece projekte

Manje pokretnih djelova.

Integrisanost (kompaktnost)

Isplativa instalacija i odrzavanje.

REEET T T2




" JAENVIODULARNOST PLC-a

U formi komponenti moze sadrzati:
CPU modul (Controller)
Modul za napajanje (Power Supply),
Komunikacioni modul (Communication module) |
Ulazno izlazni moduli (I/O modul

| Napajanje

1

| S/
o Um I Centralna procesorska : LT .

Ulazni alo e | jedinica ] 2.
senzorski 8 d —:> (CPU) L:_' Iy
uredaji _0}0_ z u (] Memorija : : :.l
—Qer O . | 1 n

Ty | |program podaci | } :‘ i

| ! | Y
Opticka 7 X Bokika
izolacija izolacija

Izlazni
izvrsni
uredaji

Programerski uredaj



" AENRNASIFIKOVANJE PLC-a

- Modularni PLC-ovi mogu biti razliCitih veliCina i klasifikuju se kao:
- mali,
- srednji, ili
- veliki.

- Klasifikacija je zasnovana na:
- mogucnostima CPU modula
- koliCini memorije
- broju ulaza i izlaza.



" «EEENNNAPAJANJE PLC-a

Napajanje PLC-a konvertuje mrezno napajanje u DC napajanje, nivoa koji
zahtijevaju CPU i unutrasnja kola 1/0 modula.

Cesto napajanje obezbjeduje izlaz nivoa 24V.




"  NNT/O moduli PLC-a

|zoliranost (galvanska odvojenost)
- Nizak napon i signale niske struje PLC koristi interno.

- Elektricna kola veCe snage su porebna za rad sa mnogim senzorima i
aktuatorima.

Diagram: Electiromagnetic or transformer isolation




" AEEERIEITALCNI IZLAZNI MODULI

RELEJNI IZLAZ

CPU 7 Output module
Out 5
5 |1 I 1
E | Actuator
- Common Power
0 ' +/- —/+

Dva spoljna kontakta: kontakt za actuator i kontakt za napajanje
Izlazno kolo je galvanski odvojeno (izolirano)

Zajednicki kontakt za grupu izlaza (ili za sve izlaze). Sva kola u grupi su povezana na
isto napajanje odnosno istu referentnu naponsku tacku.

Drugi kontakt napajanja je povezan na kontakt relea.



" -<EEENRIEITALNI1ZLAZNI MODULI

TRANZISTORSKI IZLAZ

CPU [ | Output module
N1 __-l- Out 5 — Current
T l
] B C Actuator
d. ¥ Positive '
= = common Power
| | " B
P_CPU 7 Output module
= Out 5 <— Current
5 |1 —I>{—| !
AAS |
B c Actuator
= Negative
E ]
% common Power
0 + - +

Strujni izvor
PNP tranzistor

Strujni uvir
NPN trantistor



" -<EEENRIEITALNI1ZLAZNI MODULI

TRIAKOM KONTROLISANI IZLAZ

CPU

Output module

Out 5

2

Common

|

Actuator

+/—-

Power

—+




" --EERNIEITALNI ULAZNI MODULI

Obi¢no sadrze opto-izolator za svako senzorsko kolo.

Digitalnu ulazi i senzori moraju biti kompatibilni

Input modul ini uvi
nput module Strujni uvir
+5V
< Current source
/Sensor
Power
- +
CPU 7 Input module Inii
O Strujni izvor
= In5 — Current source
5 |1 :
_— A
S b 54 Z; / Sensor
. = = Common . Power ~




" --EERNIEITALNI ULAZNI MODULI

CPU

+/—

Input module Oba smjera
+5V
% In 5
K
s X
Common Power

—/+

"/ Sensor




" AEENNPROGRAMIRANJIE PLC-a

Kao i drugi procesorski uredaji i PLC radi na bazi izvrSavanja programa koji je za njega
napisan.

Pisanje programa se izvodi na PC-u u okviru instaliranog softvera za upotrijebljeni PLC.

Svaki proizvodacC uz svoj PLC isporucuje i softver koji predstavlja kombinaciju
programskog editora, kompajlera i komunikacijskog softvera.

PLC se moze programirati i pomocu rucnih programatora, koji posjeduju LCD displej i
malu tastaturu. Direktno se povezuju sa PLC-om. Obi¢no sluze da se naprave male
izmjene u programu, kada se to mora obaviti u pogonu.



" AEENNPROGRAMIRANJIE PLC-a

PLC se moze programirati jednim od 5 standardnih (IEC 61131-3) jezika:

FBD - Function Block Diagram,

LD —Ladder Diagram (Merdevinski dijagram),
ST - Structured text,

IL - Instruction List,

SFC - Sequential function chart.



" AEEEENKONTAKTNI DIJAGRAMI

NejCesSce upotrbljavani PLC programski jezik su kontaktni dijagrami (eng. ladder
dijagrami).

Kontaktni dijagrami predstavljaju prilagodenje relejnih upravljackih kola (i njihovog
grafiCkog izgleda) principima rada PLC uredaja.

Kontaktni dijagrami nastali su na bazi strujnih upravljaCih Sema, kojima se prikazuje
protok struje u strujnom kolu i koje sluze elektriCarima za povezivanje istog.

COOLANT ON GUARD DOWN RELAY 1
BUTTON MIGROSWITCH
GCOOLANT OFF RL1AA
BUTTON
. s
L R

Sema se sastoji iz dva vertikalna mreZna voda.
Struja teCe kroz kolo sa lijeva na desno.
Svako kolo u elektricnoj Semi prikazano je kao zaseban strujni put.

Rad upravljanog uredaja odreden je uslovima.



" JAEENKONTAKTNI DIJAGRAMI

Kontaktni dijagram vrlo je sliCan strujnom putu na elektricnoj Semi.

U elektriCnoj Semi simboli predstavljaju stvarne uredaje i dato je njihovo povezivanje.

Kod kontaktnih dijagrama simboli predstavljaju naredbe u programu.

Kontaktni dijagram je dio upravljaCkog softvera PLC-a, dok elektricna Sema predstavlja

stvarni tok struje u kolu.

Elektricna Sema predstavlja stanje kontakata, dok u kontakthom dijagramu se prikazuje
kakvo je stanje nekog uslova, sto ne mora imati direktne veze sa stanjem kontakata na

ulazima i izlazima PLC-a.

LOGICKI | /1

ELEKTRICNI KONTINUITET

Taster 1 Taster 2
Slop Start

r~

STRUJN | i ‘
PUT ~ } /

LOGICKI KONTINUITET

Stop Start MOTOR-M1
1 |2 02
\

e ~0—

O1




" JAEENKONTAKTNI DIJAGRAMI

Svaki programski logiCki put mora imati najmanje jednu izlaznu naredbu.

Obi¢no sadrzi jedan ili viSe uslova koji moraju biti zadovoljeni da bi se izvrsila izlazna
naredba.

Uslovi su najcesce signali koji dolaze sa uredaja prikljuCenih na ulaze PLC-a, u
kombinaciji sa statusom izlaza, pomoc¢nih memorijskih promjenljivih, vremenskih i
brojaCkih elemenata.

Na desnoj strani svakog logiCkog puta nalazi se izlazna instrukcija, koja se
aktivira/deaktivira u zavisnosti od stanja uslova.

ELEKTRICNI KONTINUITET

Taster 1 Taster 2
ster 2 AATE
Stop Start HSTIR

| —
STRUJNI |
PUT =~

OGICKI | |
PUT ' / = i —



" AEEEENENTE'KONTAKTNIH DIJAGRAMA

NajecCesce koristene komponente:

m Ulazi (contacts)
m [zlazi (colls)

m Podaci

m Brojaci

m Tamerl
...




" ETTULAZL 1 1ZLAZ

+ NO Contact = I
+ NO Coil (Output) =C =
* NC Contact '|/|‘

* NC Coil (Output) =()=
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" -EEENNSKENEDIJAGRAMI | ARDUINO

SoapBox Snap

http://soapboxautomation.com/support-2/soapbox-snap-tutorial/soapbox-snap-
arduino-tutorial/

Timer 1 lib: https://www.arduinolibraries.info/libraries/timer-one
Phidgets deivers lib: Directory Listing (phidgets.com) (Phidget21)
Soapbox: https://soapbox-snap.software.informer.com/16.0/

Interesantni primjeri

http://www.contactandcoil.com/patterns-of-ladder-logic-programming/



http://soapboxautomation.com/support-2/soapbox-snap-tutorial/soapbox-snap-arduino-tutorial/
https://www.arduinolibraries.info/libraries/timer-one
https://www.phidgets.com/downloads/phidget21/libraries/windows/Phidget-x64/
https://soapbox-snap.software.informer.com/16.0/
http://www.contactandcoil.com/patterns-of-ladder-logic-programming/

"

SoapBox Snap Arduino Ladder Logic Tutorial

Before you can use SoapBox Snap to program an Arduino in ladder logic, you need:

A PC with Windows XP, Windows 7, or later

An Arduino UNO, Nano or Mega (R3)

The Arduing Software

(Read the Cettng Started tutorial if you've never used an Arduino before)

Install the Timer! Library for Arduino

The Phidgets Drver Library - choose the appropriate 32 or 64 Bit Installer Download and install it
Install SoapBox Snap (version 2014.07.06 or later)

Note that if you want to use an Arduino Mega or want to configure any digital pins as analog (PWM)
outputs, then you need version 2015.01.11 or later.

When you install SoapBox Snap, it will install .N}T 4 1f you don’t already have It

o if you're on Windows 8, make sure you have both the .NET framework 3.5 and 4.0 (or 4.5)

Note: I'm assuming you're familiar with ladder logic, or you wouldn't be here. | don’t assume you know C= =,

After you've completed the steps above, connect your Arduino via the USB cabie, and then open the SoapBox
Snap Arduino Firmware, which is automatically installed in this folder:

C:\Program =ilss (x86)\ScapBox Automation\SoapSox Snap\ArduinoFirmware)

Double-click on the “ArduinoFirmware.ino” file, which is an Arduino “sketch”. If you have the Arduino software
installed (linked above) then this will open the sketch in the Arduino IDE. Follow these steps to download the
firmware to the Arduino:

1. In the menu Tools->Board, make sure you have the correct Arduino board selected (to match your
physical hardware). This should be “Arduino Uno”, "Arduino Nano w/ ATmeqa328” or "Arduino Meqa



"

. In the menu Tools->Serial Port, make sure you have your Arduino’s serial port selected (remember this

port number for later 100)

. Optionally, if you have the Nano or Mega, you can edit the BoardSelect,h file and comment out the

“#define UNO" line and uncomment either the “#define NANO" or “#define MEGA" line. (Two slash marks is
a comment: /) This will allow you to use all 8 analog Inputs on the Nano, rather than only the first 6 that
are available on the Uno, or use all the available analog and digital 1/O on the Mega. If you decide to do
this, you'll have to mark the BoardSelect.h file as read /write (instead of read-only). You have to do this In
your Windows file system, not in the Arduino software.

. Make sure you've imported the Timer1 library. Go to the menu Sketch->Import Library->Add Library.

and browse for the zipped library file you djwnloaded In the pre-requisites section above. (This should be
in a folder called TimerOne, not TimerOne-¥11, or the Arduino IDE might complain.)
Now use the menu to go to File->Upload. This will first compile it and then upload it to the board.

. If it worked, the LED connected to pin 13 on the board should be blinking one short blink every 1 second,

Optionally, you can connect to the board from within the Arduino software by using the menu item Tools-
>Serial Monitor. Set the baud rate to 115200. Now you can type some commands. Try typing “status”
without the quotes and press enter. It should say "Running=False”, then "EOM", You can also try
“information”. you can even try reading the status of an Input now: “read b0" will read the status of input
pin 3, “read b1” will read the status of input pin 4, and so on. “read n0" will read the value from analog
input AQ, etc.

. Bonus: try the “device-config” command. This will read back a list of the |/O configuration. Arduino

discrete 1/ O pins are configurable as either inputs, outputs, or analog (PWM) outputs. By default all
discrete pins are configurad as inputs, but you can change a pin to an output. For example, if you want
pin 8 to be an output, send the command: “config-output 8", If you want pin 9 to be an analog (PWM)
output, send the command: “config-pwm 9" At any time, you can change them all back to inputs with the
command “config-reset”. Note that this in only for informational purposes at this time. You have to do
this through SoapBox Snap later, as you'll see, or all your configuration changes will be wiped out the first
time you download your ladder logic to the device.

When complete, you can close the Arduino software.

Now you can start SoapBox Snap. The installer will have installed a shortcut on your desktop, or you can find it

in the start menu (it's under the SoapBox Automation folder). When you start SoapBox Snap, it opens the
SoapBox Snap Start Page. On the left of the start page you will see some links. Click on the “New Program”
link. Now on the left you will see a Solution Explorer window. Inside that window, the top level object is the
Solution, and under this is the Runtime. We need to start by changing the properties of the Runtime:



"

Now you can start SoapBox Snap. The installer will have installed a shortcut on your desktop, or you can find it
in the start menu (it's under the SoapBox Automation folder). When you start SoapBox Snap, it opens the
SoapBox Snap Start Page. On the left of the start page you will see some links, Click on the “New Program”
link, Now on the left you will see a Solution Explorer window. Inside that window, the top level object is the
Solution, and under this is the Runtime. We need to start by changing the properties of the Runtime:

1.
2.

. As of version

Right click on the Runtime item and select Properties... from the context menu
In the properties page that opens, there Is a Type drop-down box. Select "SoapBox Snap Arduino Runtime”
from the drop-down list

. In the Address text box, enter the COM port of the Arduino from above (e.g. mine i5 "COM27" without the

quotes)

. Optionally, in the Configuration text box, you have to enter the 1/0 configuration information,

Unfortunately you have to be very precise here. What you need to do Is specify which discrete 1/0 pins will
be outputs (by default they're all inputs). For example, if you want pins 7 and 8 to be outputs, you would
enter on the first line: “config-output 7° (without quotes) and “config-output 8" on the next line,

j201 5.01.11, you can also configure certain pins as analog (PWM) outputs. Only some pins
are configurable as PWM outputs. They should be marked on your board, but you can look them up on the
Arduino site as well. The Uno and Nano PWM pins are 3, 5,6, 9, 10, and 11, The Mega PWM pins are 2 to
12 and 44 to 46 (pin 13 is technically a PWM pin but we're using that as a status LED), To configure one of
the PWM pins as an analog (PWM) output (e.g. pin 9), the syntax is “config-pwm 9",

. Click the Apply button in the bottom right corner of the runtime properties window
. Click the Save icon on the toolbar (looks like a floppy disk). It will ask you where you want to save the file.

That's up to you.



Runtime  Main | $ X Instructions * § X

Type: | SoapBox Snap Arduino Runtime v

¥ Execute on startup
Address:  COM27

config-output 8

—%_

Configuration:  config-output 7
_.@._
_l

Lo | [ apey | [ comet |

A note on terminology: the Arduino world talks about “uploading” sketches to an Arduino, but in the ladder
logic world we normally talk about “downloading” ladder logic programs to our PLCs. That means everything

above here was talking about uploading and everything from here down is talking about downloading, but it's
really the same direction: from the PC to the Arduino.




"

Now you have to do your first download. This will download an empty ladder logic program, plus the
Configuration you've entered, into the Arduino

1.

Make sure you've disconnected the Arduino software's Serial Port Monitor here, or else the COM port will
still be In use, and SoapBox Snap can't use it.

. Right click "Runtime” in the Solution Explorer on the left, and click Connect from the context menu
. You will be presented with an Upload Download dialog. Always select “Download” when you get this

message. This firmware does not support uploading (unless you've already downloaded and then
disconnected from the runtime but you still have SoapBox Snap open and you try to reconnect, in which
case uploading just gets back the latest download). It's technically possible to implement uploading, but
you would lose the name of all your coils, etc., and there are no plans to implement this feature (yet).

. After your download, the runtime will automatically start the ladder logic program (which does nothing

because it's empty). The LED on pin 13 wilk now be on steady, but flash off briefly once per second. You
should see two icons beside the Runtime item in the Solution explorer: a round green arrow indicating the
ladder logic Is running, and a chain link with a green arrow indicating SoapBox Snap Is connected to the
runtime. Note that while you're connected, the COM port is in use and you can't connect to the Arduino
with any other software.

. Under the Runtime item in the Solution Explorer, there is a "Device Configuration” item. Right click on

Device Configuration and select Read Device Configuration from the context menu. It will warn you that
you can't make this edit while connected. Answer “yes” when it asks if you want to disconnect. Now under
Device Configuration you will see a new item named Local | 'O.

. Expand the Local 1'0O item and all of the child items by clicking the plus (+) or arrow icons next to each

item.



"
Here Is what the solution explorer should look like, if you used the configuration shown above, with pins 7
and 8 configured as outputs

4 — Solution [New Solution]
4 ¢» Runtime
« Logic
4 J" Device Configuration
4 local VO
4 Discrete Inputs
¥ pin2
{) ¥ pin3
¥ pind
¥ pinS
¥ pinG
¢ pind
¢ pinl0
¥ pinil
¥ pinl2
4 Discrete Outputs
4§ pin?
False
4 ¢ pind
False
4 Angiog Inputs
AD
a1l



"
Now vou can go back online with the runtime and do some interesting things like monitor and force the
discrete | O values

1. Click the disk icon again to save
2. Rught click on the Runtime item and click Connect from the context menu
3. Choose the “Downioad” option from the Upload Download dialog

Now watch the ‘light bulb” icons next to the input pins. If your input pins are floating, the on. off indicators
might be turning on and off already. You can also try using a jumper to connect an input pin to the 5V or GND
pins to make it go on or off respectively. On my board, input pin 12 tends to flicker due to the LED on pin 13.

You can also force the outputs on or off from here. Right click on the “pin7” item (If you configured it as an
output) and choose Force On from the context menu. The light bulb icon next to pin7 will light up, and you
will see a forced icon (which looks like a small lightning boit). You can measure the voltage on this pin with a
voltmeter, or connact an LED to this pin throual a resistor. When you're done, please use the Release Force
item from the context menu before continuing with the tutorial.

You will notice that if you expand the output pin items, there is an item underneath that reads "False” by
default. This Is where you connect this output to your logic. By default, the output is driven by a hard-coded
‘False” signal, so unless you force it on, the output will be off. You can change this to a constant “True”
(always on, unless forced off), or you can connect it directly to an input pin, or a signal (like a coil) in your
logic. To change the connection, double click on where it says “False” and this will open a Signal Chooser
dialog. The top option Is a hard coded value (enter either True or False here), or you can use the bottom
option and select either a coil from your logic, or one of the input signals to drive it from.

A note about “Signals™ in traditional PLCs we frequently talk about bits, tags, addresses or memory locations.
While this is true at a very low level in the runtime, SoapBox Snap Implicitly creates these things when
necessary and you don't need to be concerned about them. When you drop a coil on a ladder rung, it implicitly
allocates one bit of memory and automatically assigns the “signal” the name that you give to the coil. That
means you can think of the coil, the signal, and the memory location that stores the state of that variable as
all one-and-the-same. It's just “a coil”. When rou drop a contact on a rung, you use the Signal Chooser (or
just type the signal name using the auto-complete textbox) to select a coil or other boolean signal to
reference in that contact. Likewise, when you use a rising-edge instruction, you don't need to allocate a
special memory location to hold the state, since this |s done for you. Counters and timers work the same,
except that they implicitly define more than one signal each, such as "Done” boolean signals and "Current
Value" numeric signals. One benefit of implicitly allocating memory Is that it prevents the "beginner mistake”
of using the same memory location in two different coll instructions. Most importantly it means you can focus
on writing ladder logic instead of managing memory and tags.



"
Note: If you want to read the values of the signals over the serial port (such as into an HMI program) you'll
need some way to map the signal names into the internal addresses in the Arduino. As of version 2015.11.01,
you can now export a signal table to do exactly this. At the top of the screen, go to Tool -> Options.. and go
to the Soapbox Snap Arduino Runtime options page. Check the box there for Export Signal Table, and in the

text box, enter the fully qualified directrory where you want it to export, The next time you download your
logic to the Arduino. it will write the signal table to a .csv file in that directory.

Writing ladder logic for the Arduino Runtime Is the same as for the Soft Runtime that's included in SoapBox
Snap. Open the main ladder logic page by expanding the solution explorer tree under Runtime->Logic and
then double-~clicking on the Main item. A single empty rung will have been created by default, The available
instructions show up in a visual list on the night. You can drag and drop these instructions onto the rung. New
rungs can be added by right clicking in the ladder editor and using the context menu. All of the Instructions
except “Find Text” will work with the Arduino Runtime (it has no use for String instructions right now). Note
that each rung is called a "group” or “instructidn group” (for reasons that are unimportant),

SeapBox Snap supports online debugging but not online editing, so you have to disconnect to make vour edits
and then connect again to download your changes. Some things to note:

e The ladder logic program is stored in the Arduino's EEPROM memory, so it will survive a reboot or loss of
power

* There Is no “retained” or “persistent” memory, so all of your coils, timers, counters, etc. will revert to
default values, both on a download or turning off the power

e Connecting to the Arduino with SoapBox Snap doesn’t cause a reset, but connecting with the Arduino
Software’s Serial Port Monitor will

® The current version of the runtime limits the size of the ladder logic program to 750 bytes (3750 on the
Mega), including overhead stuff. This probably equates to about 50 “average” rungs (250 on the Mega),
but this obviously depends greatly on the complexity of your rungs.

o If you want to see how big the downloaded program Is, connect to the runtime with the Arduino
software's Serial Port Montor, set baud to 115200, line ending to NL & CR and type “information” without
the quotes, and press enter. Among the information reported will be the max size and the current
program size.

* Pin 13 is hard coded to be the status LED so that 1/O pin Is not available. Likewise, pins 0 and 1 are hard
coded to be used by the hardware serial port, so your available pins are only 2 through 12 (plus the
analog inputs). On the Mega you have 16 analog inputs and additional pins 14 through 53.



" MEEEEESENI DIJAGRAM | LOGICKE OPERACIJE

LOGICKI KONTINUITET

— — ]

sSwiatchl Swatch

Input A Input B Output Input A

| L] L
Ll 1] X Input B

(a)

Output

(b)



" EEEENEDIVAGRAM | LOGICKE OPERACIJE

LOGICKI KONTINUITET

>
| Switchl | Lightl

R (W




" JAEENKONTAKTNI DIJAGRAMI

Moze se izvesti kompletna bulova algebra.

Obicno postoji vise logickih linija u kontaktnom dijagramu.

|zlazno stanje moze da se koristi u logiCkoj operaciji odlucivanja

START STOP IR




" T TAIJMERI

m Vrlo jednostavan koncept tajmiranja.
m 2 oshovna tipa, on-delay i off-delay
m Logika kao izlaz.



" NN ONDELAY TAJMERI

L1 L2

.—u// o @—.
51

° s

PL1

TH1

L1 12
¢ —o @—‘
s1
s

R
\ PL1
TR1 Zatvara se 5 sekundi
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" JAENENOFEE DELAY TAJMERI
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" JEEENTT BROJACI

m Broji broj pritiskanja tastera, etc.

m 3 tipa
Up Counter
Down Counter
Up-Down Counter



" JEEET ZA VJEZBU

1. Kontrolisati rad CRVENE LED diode, tako da se po pritisku tastera T1, LED
ukljuCuje ukoliko je digitalni ekvivalent napona na potencionetru veci od 800. (1
poen)

2. Kontrolisati rad CRVENE LED diode, tako da se po pritisku tastera T1, LED
ukljuCuje ukoliko je digitalni ekvivalent napona na potenciometru veci od 800. Po
pritisku tastera T2 iskljuciti LED, ukoliko je digitalni ekvivalent napona na istom
potenciometru manji od 400 (2-1 poen)

3. Kontrolisati rad zute LED, tako da se dioda ukljucCi 5 sekundi nakon otpustanja
tastera T1 i bude ukljucena 3 sekunde. Ukoliko je broj pritisaka tastera T1 veci od 3,
po iskljucenju zute LED ukljuciti plavu LED, u trajanju 3 sekunde. (3-2-1)

4. StepenisSni automat za ulaz sa dva sprata. Po detekciji pokreta na spratu 1, ukljuciti
crvenu LED. Po detekciji pokreta na spratu 2 ukljuciti zelenu LED. LED treba ostati
ukljuCena 5 sekundi i po izostanku detekcije pokreta. Diode treba ukljuCivati samo u
sluCaju niskog inteziteta spoljasnjeg svjetla. (4-3-2)



